[ 前へ | 目次 | 次へ ]

各メニュー機能解説

ここでは、リニアングラフ3Dのメニューバーに並ぶ、各メニューの詳細機能について解説します。

※ 本文中で「 / 」区切りの項目は、前半が日本語モードでの表記、後半が英語モードでの表記です。

ファイル メニュー / File Menu

ファイルを開く / Open File

座標値ファイルを開きます。一度に複数のファイルを指定可能です。 「OPEN」ボタンを押してプロットしたい座標値ファイルを追加していき、最後に「PLOT」ボタンを押してください。

データを開く / Open Data

ファイル化されていない数列データをそのままプロットする事ができます。 「DATA:」と書かれている下の入力ウィンドウに、座標値ファイルの中身を貼り付けたり、表計算ソフトで領域をコピーして張り付けてください。 「PLOT」を押すとグラフにプロットされます。

※この操作は、グラフ画面を右クリックすると出現するメニューから、「Paste Data」を選択しても行えます。

画像の保存 / Save Image

現在のグラフ画面を画像ファイルに出力します。形式はBMP、JPEG、PNGが指定可能です。任意の名前を入力して「Save」ボタンを押してください。

画像は特に指定しない場合、開いている座標値ファイルのある場所に保存されます。任意の場所に保存したい場合は「Location」項目の「SET」ボタンを押し、保存場所を指定してください。

また、JPEG形式画像ファイルでは、「Quality」項目で品質の指定が可能です。品質を上げるほど綺麗な画像に仕上がりますが、ファイルサイズが大きくなります。なお、BMP及びPNG形式では全く非劣しない完全品質で出力されます。

設定の保存 / Save Setting

現在の設定を保存します。設定ファイルの保存場所は、以下から選択できます。

1: ソフトウェアの場所 / Software Directory
2: データファイルの場所 / Data-File Directory
3: ホームディレクトリ / Home Directory
4: クイック設定 / Quick Setting

1 と 3 は、リニアングラフ2Dの起動時に毎回自動で読み込まれるため、基本設定を保存するのに用います。 2 は現在開いているデータファイルと同じフォルダに保存され、そのフォルダ内のファイルを開いた際に読み込まれます。 4 は画面右上のクイック設定セレクタに設定を追加します。

編集メニュー / Edit Menu

クリア / Clear

現在のグラフ情報を全てクリアします。

範囲の設定 / Set Range

グラフにプロットする範囲を指定します。X、Yそれぞれに最小値と最大値を入力してください。

色の設定 / Set Color

グラフの色を設定します。 同時に複数の座標値ファイルを読み込んだ場合や、複数系列の座標値ファイルを読み込んだ場合に、ここでの設定に基づいて色分けされます。

フォントの設定 / Set Font

グラフ画像中の目盛り表示やタイトル、ラベルなどに使用するフォントを設定します。 一般にフォントは著作権により保護されており、個別にライセンスが存在します。 (重要)リニアングラフで作成した画像を、論文やインターネット等を通じて第三者に公開する場合は、その行為がライセンスにより許されているフォントを使用してください。

なお、ソフトウェアとの相性により使用不可能なフォントが存在するため、設定したものと別のフォントが使用される事があります。 リニアングラフで初めて使用するフォントがある場合、画像を公開する前に、設定したフォントが正しく使用されているかを必ずご確認ください。

目盛りの設定 / Set Scale

X方向とY方向への、目盛りの数を設定できます。さらに、「Format」項目で目盛り数字の書式を指定可能です。 書式を指定するには、「Auto」項目を選択解除し、「Format=」の右にある入力エリアに、以下の例に基づいて入力してください。 絶対値が0.1以上10以下の場合を独立に指定可能です。

- 入力例 -
「 1.23 」のように表示したい場合
「 0.00 」と入力してください。
「 1.23E4 」のように表示したい場合
「 0.00E0 」と入力してください。
小数を切り捨てて「 1 」のように表示したい場合
「 0 」と入力してください。

描画の設定 / Set Rendering

グラフスクリーンの幅と高さや、余白の設定などを行う事ができます。 アンチエイリアス(文字や点・線などの描画の際、境界を滑らかにし、ピクセルによるギザギザを目立たなくする処理)の有効/無効もここで切り替えられます。

オプション メニュー / Option Menu

線プロット / With Lines

座標点を線で結ぶオプションです。

点プロット / With Points

座標点を点で描画するオプションです。

ドットプロット / With Dots

座標点を微小な点で描画するオプションです。

ボールプロット / With Balls

座標点を任意サイズの丸で描画するオプションです。

対数軸 X, Y / Log X, Y

グラフを対数軸で表示するオプションです。このモードを使用するには、座標値データが0や負の数を含んでいない必要があります。

なおリニアングラフでは、対数軸の底が10であるか自然数(ネイピア数)であるかを気にする必要はありません。 というのも、底の変換公式により、両者のグラフはそもそも比例関係にあり、目盛りの数字が異なるだけです。 そしてリニアングラフでは、目盛りの数字にその位置の対数値では無く、その位置の真の値を表示する仕様になっています (例えば1000の位置には、3ではなくそのまま1000と表示されます)。従って、対数軸の底によらず全く同じグラフとなるため、底を気にする必要が無いのです。

- 対数軸表示で、目盛りの数字を綺麗に揃えるには -

通常軸表示では、目盛りの数字が等差数列となるため、プロット範囲の最大値・最小値を綺麗な値に揃えていれば、目盛りの数字も綺麗な値に揃います。 しかしこれを対数軸表示で行っても、端数の多い数字になってしまします。

これを解決するには、対数軸表示における目盛りの数字が等比数列となる事を利用します。 まず、最大値・最小値を10の何乗かに設定しておきます。そして例えば最大値÷最小値が10の5乗になったとすれば、目盛りの本数を5本に設定します。 こうすると、各目盛りが公比10の等比数列となるので、目盛り数字を綺麗に揃える事ができます。

グレースクリーン / Gray Screen

背景を灰色にするオプションです。OFFにすると白い背景になります。灰色の背景は液晶画面での作業に適しており、白色の背景は印刷に適しています。

グリッド線 / Grid Line

背景にグリッド線(目盛りと目盛りを繋ぐ垂直・水平線)を描画するオプションです。

ゼロレベル線 / Zero Line

X=0及びY=0の垂直・水平線を描画するオプションです。

フレーム / Frame

灰色の領域と余白との境界線を描画するオプションです。

目盛り / Scale

目盛りを描画するオプションです。

精密目盛り / 8byte-Scale

目盛りの表示桁数を、8Byte浮動小数点数の有効桁(約16桁)まで表示するモードです。

ツールメニュー / Tool Menu

アニメーション / Animation

グラフをアニメーションとして表現するツールです。メニューからこの項目を選択すると、アニメーションを制御するためのウィンドウが出現します。

まず、アニメーションツールの下部にある「モード/MODE」の選択項目で、アニメーションの形式を選択してください。

- 各モード詳細 -
INDEX
曲線/点プロットにおいて、始点から終点までをアニメーションします。
TRACE
曲線/点プロットにおいて、始点から終点までをアニメーション(上描き)します。
INDEX-SERIES
時刻ごとに系列を切り替えてアニメーションします。

なお、系列を時刻とするアニメーション(INDEX-SERIES)では、2カラム書式の座標値ファイルにおいて、空白改行が系列の区切りと見なされます。 マトリックス書式の座標値ファイルでは、異なる列に属するY値は別の系列と見なされます。

その後、「PLAY」ボタンで再生、「STOP」ボタンで一時停止ができます。 一般的な動画プレイヤーのように、右側の大きなバーで任意の時刻に飛ぶ事ができます。 またその下の小さなバーで再生スピードを調整できます。アニメーションを終了したい場合は、アニメーションウィンドウを閉じてください。

数式プロット / Math

数式から座標値データを生成し、グラフにプロットするツールです。「Y(<X>)=」と書かれた入力ウィンドウ中に数式を記述して「PLOT」ボタンを押すと、 その数式のグラフが描画されます。なお、数式中にはX軸変数を<X>と記述する必要があります。

※ 現在は「 プログラム / Program 」メニューから、新しい数式プロットツールが使用できます。 このツールは旧バージョンですが、こちらの操作感に慣れた方のために互換サポートしています。

プログラム メニュー / Program Menu

リニアングラフ2Dが標準サポートしているスクリプト言語である、VCSSLで記述されたプログラムを実行します。 プログラムはユーザーが作成可能で、リニアングラフ2Dを制御して、自動処理などを行わせる事ができます。詳細は後の章を参照してください。

VCSSLで記述したプログラムを「 RinearnGraph2DProgram 」フォルダ内に入れておくと、このメニューからすぐに選択して実行する事ができます。 標準では、数式プロットツールとして使えるプログラムなどが同梱されています。



スポンサーリンク


スポンサーリンク

この階層の目次
お知らせ

Vnanoのソースコードと開発リポジトリをGitHubで公開
2018年09月30日 - 現在開発中の、ソフトウェア上でのスクリプト処理用途に向けた小型・軽量スクリプトエンジン「 Vnano 」のソースコード&リポジトリを公開しました。ビルド・使用方法や、現状の段階と今後などを解説します。

リニアングラフ3D&2D Ver.5.6 リリース! Java言語のプログラムからも制御可能に
2018年08月19日 - 約5年ぶりの大きなバージョンアップを迎えた、新しいリニアングラフ Ver.5.6の特徴をご紹介します。UIがリファインされ、Java言語でグラフ描画ライブラリとして使う事も可能になりました。

ライセンスの緩和方向への改訂を実施、条件を満たす場合のソフトの再配布などが可能に
2018年07月16日 - RINEARNでは2018年7月に、ソフトウェアライセンスの緩和方向への改訂を実施しました。新ライセンスでは、いくつかの条件を満たす場合において、ソフトの再配布などが無申請で可能になりました。

コードアーカイブ新着
配列を3Dグラフにアニメーションプロットする(点/線グラフ)

座標値配列の内容を、3次元の点/線グラフに連続でプロットし、アニメーションさせるサンプルプログラムです。
2018年11月14日
配列を2Dグラフにアニメーションプロットする

座標値配列の内容を、2次元グラフに連続でプロットし、アニメーションさせるサンプルプログラムです。
2018年11月13日
配列を3Dグラフにプロットする(曲面/メッシュグラフ)

座標値配列の内容を、3次元の曲面/メッシュグラフにプロットするサンプルプログラムです。
2018年11月12日
ファイルを3Dグラフにプロットする(曲面/メッシュグラフ)

座標値ファイルの内容を、3次元の曲面/メッシュグラフにプロットするサンプルプログラムです。
2018年11月11日
連番画像をアニメーション再生する簡易ツール

フォルダ内の連番画像ファイルを、動画への変換不要で、そのままアニメーションとして再生できる簡易ツールです。
2018年09月04日
公式Twitterアカウント

スポンサーリンク