[ 前へ | 目次 | 次へ ]
Japanese English

起動・プロット方法

リニアングラフ3Dを起動してグラフをプロットするには、いくつかの方法が用意されています。 ご利用の用途に合わせた方法で起動してください。

リニアングラフ3Dのダウンロード

ダウンロードしたZIP形式のファイルの展開方法

ダウンロードしたままのリニアングラフの配布ファイルは、圧縮されたZIP形式のファイルになっています。 まずは、そのZIPファイルを右クリックして 「すべて展開」や「ここに展開」などを選び、展開してください。 すると、元のZIPファイルと同じ名前のフォルダが出現し、その中にZIPファイルの中身が入っています。以降、その中のものを使用してください。 元のZIPファイルはもう不要です。

展開がエラーで中断されてしまう場合は…


「問題を引き起こす可能性〜」などのエラーが表示されて展開を完了できない場合、ZIPファイルを右クリックして「プロパティ」を選択し、 プロパティ画面の下にあるセキュリティ項目の「許可する」にチェックを入れて「OK」すると、以降は展開可能になります。 このエラーは、インターネット等から入手した不明なプログラムを安易に実行しないための、OSのセキュリティ機能によるものです。

ファイル名の日本語が文字化けしてしまう場合は…


Linux® 等をご使用の場合で、展開結果のファイル名の日本語が文字化けしてしまう場合があります。 その場合、コマンドライン端末から以下のように unzip コマンドで展開してみてください:

cd ZIPファイルのある場所
unzip -O cp932 ZIPファイル名

効果が無かった倍は、他の展開ソフトを使用するか、展開後に convmv コマンドなどで文字化けの修復処理を試してみてください (日本語ファイル名は CP932 でエンコードされています)。

簡単な起動方法

ZIPファイルを展開できたら、まずは最も簡単な方法でリニアングラフ3Dを起動してみましょう!

Microsoft® Windows® をご使用の場合(※コマンドでの利用は後述のこちらを参照)

Windows® をご使用の場合は、展開したフォルダ内の 「 RinearnGraph3D_?.?.?.bat (種類はバッチファイル、「?」の箇所はバージョン番号の数字) 」 をダブルクリックすると起動します。 最初に設定や初回処理について尋ねられるので、適時答えると、リニアングラフ3Dが起動します。2回目以降はすぐに起動します。

特定の拡張子のファイルをダブルクリックするとリニアングラフ3Dで開かせたい場合は、 そのファイルを右クリックして「プログラムから開く」メニューで、上記のバッチファイルで開くように指定します。

Linux® 等やその他のOSをご使用の場合(※コマンドでの利用は後述のこちらを参照)

Linux® 等やその他のOSをご使用の場合は、展開フォルダ内の 「 RinearnGraph3D.jar (JARファイル) 」をコマンドライン端末から:

cd 展開したフォルダ
java -jar RinearnGraph3D.jar

と入力して実行できます。必要に応じて、javaコマンドに「-Xmx」オプションを追加してメモリー容量を指定できます (例:512MB使用するなら「 java -Xmx512m -jar RinearnGraph3D.jar」)。

javaコマンドが使用できない場合は…


もし、javaコマンドが使用できない旨のエラーが出る場合は、Java®実行環境(JRE)を導入する必要があります。 aptコマンドが使える環境では、まずコマンドライン端末上で:

apt search jre     (または apt の代わりに apt-cache )

して入手可能な一覧を確認の上で、コマンドラインで以下の例のように導入できるかもしれません(環境依存):

sudo apt install default-jre     (または apt の代わりに apt-get)
または
sudo apt install openjdk-?-jre     (? の箇所にはバージョン番号の数字が入ります)

他のものでも構いませんが、リニアングラフ3Dが動作しないものもあります (※末尾に -headless が付いているものでは動作しないので、付けないようご注意ください)。

起動後、ファイルをプロット(グラフに描画)する方法

より高度な起動設定などは後に回して、まずはファイルをプロットしてみましょう!

起動後、メニューバーから「ファイル/File」 > 「ファイルを開く/Open File」メニューを選択し、プロットしたいファイルを選択してください(「/」の後は英語モードでの表記です)。

「OPEN」ボタンでファイルを選択すると、それが上のテキストエリアに追加されます (ダウンロードしたパッケージの「SampleDataFile」フォルダ内に、いくつかサンプルファイルが同梱されています)。 プロット対象ファイルを全て追加したら、「PLOT」ボタンを押して、グラフにプロットしてください。

( ※ ファイルを開くのではなく、表計算ソフト上などのデータを直接プロットしたい場合は、表計算ソフト上でデータを選択コピーし、 グラフ画面上で右クリックして 「 データの貼り付け(Paste Data) 」 を選択してください。)

以下の図は、適当なファイルを1個プロットした例です。標準ではこの図の通り、各座標の位置に点がプロットされます。 この点の色は、座標のZ値に応じたグラデーションで色分けされています(後で説明する通り、無効化して単色にもできます)。

メニューバーから「オプション/Option」 > 「線プロット/With Lines」のチェックを入れると、下図の通り、各点が線でつながれます。

データがメッシュ形式( 「 5. 座標値データ書式 」参照 )に対応している場合は、 同様に「オプション/Option」 > 「曲面プロット/With Membranes」を選択すると、 下図右側のように各座標を四角形でつないた曲面が描画されます。

さらに「オプション/Option」 > 「テッセレーション/Tessellation」を有効化すると、下図のように曲面の座標が密に補間され、 なめらかになります。 補間の結果、面が元のプロット範囲からはみ出て切れる場合は、「編集/Edit」>「範囲の設定/Set Range」で調整してください。

ファイルを複数選択してプロットした場合は、下図左側の通り、 それぞれのファイルのデータが重ねてプロットされます。 それぞれのファイルのデータは、内部ではちゃんと異なる系列のものとして区別されているため、 色分けする事もできます。メニューバーから「オプション/Option」 > 「グラデーション(Z値)/Gradation Z」のチェックを外すと、下図右側のように色分けされます。

なお、1つのファイル内に複数系列のデータが含まれている場合( 「5. 座標値データ書式」参照 )、同様にグラデーションを無効化すると、系列ごとに色分けされます。

メモリーが不足する場合は…


プロットするファイルのサイズによっては、メモリーが不足し、「メモリーエラー」や「Memory Error」などとメッセージが表示されて ソフトウェアが終了してしまいます。

その際、Microsoft Windows をご使用の場合は、「 SetMemorySize_メモリー容量設定.bat (バッチファイル)」をダブルクリック実行し、メモリー容量を大きめの値に再設定してください。

Linux等やその他のOSをご使用の場合は、「簡単な起動方法」の項目で述べた通り、javaコマンドに -Xmx オプションを付加して実行してください。 ただし後述のパス設定を行って ring3d コマンドをご使用の場合は、リニアングラフ3Dの「 bin 」フォルダ内の「 ring3d 」というファイル(拡張子なし) をテキストエディタで開き、中の java コマンド実行部に -Xmx オプションを追記してください。

コマンドライン端末上で常用する場合の設定

リニアングラフ3Dを、コマンドプロンプトやシェルなどのコマンドライン端末上で常用したい場合は、 リニアングラフ3Dをダウンロード・展開したフォルダ内の「 bin 」というフォルダのパス(場所)を、 環境変数 Path または PATH に設定します(後述)。すると ring3d コマンドが使用可能になり、

ring3d a.dat3d

とコマンド入力するだけで、リニアングラフ3Dを起動してファイル「 a.dat3d 」をプロットできるようになります。 空白を挟んで、複数のファイルをプロットする事もできます:

ring3d a.dat3d b.dat3d

Microsoft® Windows® をご使用の場合のパス設定

まずは、リニアングラフ3Dのフォルダをどこか適当な場所へ配置(ずっとそこへ置きます)してください。 その後にパス設定を行いますが、バージョンによって画面の開き方や手順が異なるため、詳細は「 Windows Path 設定 」などで検索してみてください。

参考までに、Windows 10 をご使用の場合は:

スタートボタン
> 歯車アイコン(設定)
> 「環境変数を編集」と検索して移動
> 開かれた画面で「ユーザー環境変数」の一覧から「Path」(無ければ作成)を選び「編集」
> 「新規」を押し、リニアングラフ3Dの「bin」フォルダのパスを入力

(※ Shift キーを押しながら bin フォルダを右クリックすると、メニューからパスのコピーを行えます)

で行えますが、誤って他の値をいじったり、削除してしまったりすると大変な事になるのでご注意ください (上の説明で、システム環境変数への登録もできますが、その点を考慮してユーザー環境変数に登録しています)。 手慣れた方に依頼できる場合は、行ってもらう方が無難かもしれません。

Linux® 等やその他のOSをご使用の場合のパス設定(および実行権限設定)

まずは、リニアングラフ3Dのディレクトリ(フォルダ)をどこか適当な場所へ配置(ずっとそこへ置きます)してください。 ここでは例として以下の場所に配置したとします。

/usr/local/bin/rinearn/rinearn_graph_3d_?_?_?/
(※ ?_?_? の箇所はバージョン番号です)

続いてcdコマンドでこの場所のさらにbinディレクトリまで移動し、以下のコマンドを実行します:

chmod +x ring3d
(起動用のシェルスクリプトに実行権限を付加しています)

最後に、ユーザーのホームディレクトリにある、「.bashrc(隠しファイル)」または「.bash_profile」もしくは「.profile」 (どのファイルが有効かはオペレーティングシステムによって異なります)をテキストエディタで開き、最終行に下記の一行を追記してください。

export PATH=$PATH:/usr/local/bin/rinearn/rinearn_graph_3d_?_?_?/bin/
(※ ?_?_? の箇所はバージョン番号で置き換えてください)

$PATH:以降の内容は、リニアングラフ3Dのディレクトリを配置した場所に合わせてください。

グラフ画面が粗い場合は…

リニアングラフ3Dでグラフを描画した際、環境によっては、ウィンドウ上に表示されるグラフの文字や線の境界などが、 ギザギザが目立つ印象で粗く表示される場合があります(例:下図)。

拡大率125%時の図

※ 分かりやすくするため、実際の画面上での大きさよりも引き延ばして表示しています。

これは、ご使用のPCにおいて、ディスプレイに内容を拡大して表示する設定になっている際などに生じます。 この設定は、例えば Microsoft® Windows® をご使用の場合、デスクトップを右クリックして「 ディスプレイ設定 」などから拡大率の設定を確認・変更できます。

※ OS側のこの機能に問題があるわけでは全くなく、ソフトウェア側を含めた色々な事情でやむを得ない現象です。

ディスプレイの拡大率がちょうど100%でない場合、上のように文字や線の境界が粗く表示される事があります。 100%に設定した際の画質は下図の通りです(これが本来の画質です):

拡大率100%時の図

※ 分かりやすくするため、実際の画面上での大きさよりも引き延ばして表示しています。

ただし、画質が粗くなるのは、あくまでもウィンドウ上での見かけだけであって、グラフ画像をファイルに保存したり、 右クリックでコピーしたりする際の画質には全く影響しません(100%表示時と同じ画質になります)。 そのため、見づらくて作業が難しいレベルでなければ、無理にディスプレイの拡大率を100%にして使用する必要はありません。

※1: OracleとJavaは、Oracle Corporation 及びその子会社、関連会社の米国及びその他の国における登録商標です。文中の社名、商品名等は各社の商標または登録商標である場合があります。
※2: Windows は、米国 Microsoft Corporation の米国およびその他の国における登録商標です。この記事は独立著作物であり、Microsoft Corporation と関連のある、もしくはスポンサーを受けるものではありません。
※3: Linux は、Linus Torvalds 氏の米国およびその他の国における商標または登録商標です。
※ その他、文中に使用されている商標は、その商標を保持する各社の各国における商標または登録商標です。


スポンサーリンク



Japanese English
スポンサーリンク

この階層の目次
新しいお知らせ

Vnanoのスクリプトエンジンアーキテクチャ解説2: コンパイラ
2019年07月03日 - オープンソースで開発中のスクリプトエンジン「 Vnano 」のアーキテクチャを解説する連載の第2回です。今回は、スクリプトを中間コードへと変換する、コンパイラ部分の内部をクローズアップして解説します。

Vnanoのスクリプトエンジンアーキテクチャ解説1: 全体像
2019年05月28日 - RINEARNでは現在、 アプリケーション組み込み用スクリプトエンジン「 Vnano 」を、オープンソースで開発中です。今回は、このスクリプトエンジンのアーキテクチャ面を掘り下げて解説します。複数回の連載予定です。

リニアンプロセッサー nano の先行開発版やソースコードリポジトリを公開
2019年04月16日 - オープンソースで開発中の小型プログラム関数電卓ソフト、「 リニアンプロセッサー nano 」の先行開発版やソースコードリポジトリを公開しました。概要と使用方法、ビルド方法などについて解説します。

コードアーカイブ新着
連番ファイルから3Dグラフをアニメーション描画するツール

フォルダ内の連番データファイルを読み込み、3Dグラフを高速で連続描画して、アニメーションさせるツールです。グラフを連番の画像ファイルに保存する事もできます。
2019年06月03日
連番ファイルから2Dグラフをアニメーション描画するツール

フォルダ内の連番データファイルを読み込み、2Dグラフを高速で連続描画して、アニメーションさせるツールです。グラフを連番の画像ファイルに保存する事もできます。
2019年05月24日
[公式ガイドサンプル] 立体モデルを生成して3D空間に配置する

「VCSSL 3DCG開発ガイド」内のサンプルコードです。立体モデルを生成し、3D空間に配置します。
2019年05月21日
[公式ガイドサンプル] ポリゴンを生成して3D空間に配置する

「VCSSL 3DCG開発ガイド」内のサンプルコードです。立体の基本的な構成要素となるポリゴンを生成し、3D空間に配置します。
2019年05月20日
[公式ガイドサンプル] CSVファイルにデータを書き出し&読み込んで、複雑な3次元曲面のグラフを描く(魔法陣形)

「VCSSLスタートアップガイド」内のサンプルコードです。CSVファイルにデータを書き出し、さらにそれを読み込んで、魔法陣のような3次元曲面のグラフを描画します。
2019年05月17日
公式Twitterアカウント

スポンサーリンク