[ 前へ | 目次 | 次へ ]
Japanese English

画面と操作方法

ここでは、リニアングラフ3Dの画面デザインと、各部の操作方法を解説します。

Sponsored Link


リニアングラフ3Dの画面全体(グラフ画面)

リニアングラフ3Dを起動すると、以下のような、3Dグラフが大きく表示された画面が立ち上がります。

これが「グラフ画面」という画面です。リニアングラフ3Dの全ての操作は、この画面からスタートします。他にも、各種設定などのための画面がいくつか存在しますが、それらはグラフ画面のメニューバーから開きます。

以下では、グラフ画面上にある、各種の操作部品(GUIコンポーネント)を紹介しつつ、使い方を説明します。

グラフスクリーン

まず、画面中央に大きく3Dグラフが描かれている領域が「グラフスクリーン」です。

マウスのドラッグで視点を操作

グラフスクリーン上では、以下のマウス操作を組み合わせて、見たい場所を直感的にクローズアップして確認できます。

左ドラッグ
グラフを見る角度を回転できます。
右ドラッグ
グラフがスクリーン上で描かれる位置を、上下左右に平行移動できます。
ホイールスクロール
表示倍率を拡大・縮小できます。

右クリックメニュー

グラフスクリーン上において、マウスの右ボタンをクリックすると、右クリックメニューが表示されます。 右クリックメニューでは、他のソフトとの連携作業において便利な機能が提供されています。

画像のコピー
画像をコピーし、別のソフトウェアにそのまま貼り付ける事が可能です。
データの貼り付け
別のソフトウェアで選択コピーした数列データを、ファイルを作る事無く、そのままプロットする事が可能です。 「表計算ソフトなどでプロットしたい範囲を選択コピーし、リニアングラフに貼り付けてグラフ化する」といった使い方が可能です。

次元長さバー

グラフスクリーンの左側に並ぶ3本のバーは、X/Y/Z軸の長さを調整できる「次元長さバー」です。

グラフの各軸の比率を調整したい時や、どれかの軸方向の凹凸を拡大して確認したい時などに便利です。

なお、このバーでどれかの軸の長さを 0 にすると、グラフを平面化できますが、そういった用途には、メニューバーの「オプション」>「平面化」を使う方が便利です。

メニューバー

画面の上部に、「ファイル 編集 オプション ...」などのように項目が並んでいるバーが「メニューバー」で、各項目を「メニュー」と呼びます。

グラフの細かい設定や、プロットオプション(点で描くか線で繋ぐかなど)などは、このメニューバーの各メニューを選んで調整します。詳細は次回の 各メニュー機能解説 で解説しますが、以下で概要のみ紹介しておきましょう:

「ファイル」メニュー

データファイルを開いたり、設定ファイルを保存・読み込みしたりなど、ファイルに関する操作を行うためのメニューです。

「編集」メニュー

グラフの細かい設定を行うためのメニューです。例えば、グラフの各軸の範囲や、軸ラベルの表記、カメラアングルの設定などです。ただ、プロットオプションについては、すぐ下で述べる「オプション」メニューから行います。

「オプション」メニュー

グラフの描き方に関する、ON/OFF形式のオプション項目が並んでいるメニューです。例えば「点プロット」オプションは、各座標値の位置に点を打つかどうかを選択できます。また、「線プロット」オプションは、各座標値を線で繋ぐかどうかを選択できます。

「ツール」メニュー

アニメーションツールなど、補助的なツール類を提供するメニューです。

「プログラム」メニュー

簡易プログラミング言語「VCSSL」で記述されたスクリプトを実行できます。VCSSLでは、リニアングラフ3Dを制御して、自動処理やデータの下処理などを行う事ができます。詳しくは VCSSLによる制御・自動処理](./vcssl) の回で解説します。

よく使うVCSSLプログラムは、「RinearnGraph3DProgram」フォルダ内に入れておくと、このメニューからすぐに選択できて便利です。

クイック設定セレクタ

メニューバーの右端には、選択ボックスが埋め込まれていますが、これは「クイック設定セレクタ」です。このセレクタには、複数の設定を登録しておいて、すぐに切り替える事ができます。

ここで選択可能な設定は、「ファイル」メニューの「設定の保存」において、保存場所に「クイック設定」を選べば追加できます。もしくは、「RinearnGraph3DQuickSetting」フォルダ内に、手動で設定ファイルを追加・整理してもOKです。



スポンサーリンク



Japanese English
この階層の目次
新しいお知らせ

各ソフトウェアをアップデート、リニアングラフのコマンド拡張やVCSSLの英語対応など
2024/02/05 - 各ソフトの一斉アップデートの内容をお知らせします。今回は、リニアングラフのコマンド機能を大幅拡張したのがメインです。また、VCSSLのメッセージ類の英語対応も行いました。

Vnano の Ver.1.1 で実装した反復計算高速化の内側
2024/01/17 - 前回のお知らせ記事の続編です。スクリプトエンジン Vnano の Ver.1.1 において実施した高速化を、エンジン内部の実装面から掘り下げて解説します。

スクリプトエンジン Vnano の Ver.1.1 を公開、同じ内容の反復実行が劇的に高速化
2023/12/22 - スクリプトエンジン Vnano の最新版を公開しました。同じ計算式やスクリプトを反復実行する速さが、大幅に向上しました。次期版リニアングラフ3D内での活用例を交えつつ、詳しく解説します。

コードアーカイブ新着
[公式ガイドサンプル] 各種の図形や画像を描画する

「VCSSL 2DCG開発ガイド」内のサンプルコードです。図形や画像などを描画します。
2022-12-16
角度の「度」とラジアンとを相互変換し、図示もするツール

45度などの「度」の値と、ラジアンの値とを相互に変換できるツールです。対応する角度の図示もできます。
2022-11-22
[公式ガイドサンプル] 立体モデルを回転させるアニメーション

「VCSSL 3DCG開発ガイド」内のサンプルコードです。立体モデルを、アニメーションで回転させ続けます
2022-11-18
[公式ガイドサンプル] 立体モデルを回転させる

「VCSSL 3DCG開発ガイド」内のサンプルコードです。立体モデルを、指定した角度だけ回転させます。
2022-11-17
[公式ガイドサンプル] 四則演算の計算順序や、カッコを使った順序指定

「VCSSLスタートアップガイド」内のサンプルコードです。四則演算が計算される順序や、カッコを使って順序を指定する方法を例示します。
2022-10-31