[ 前へ | 目次 | 次へ ]
| 日本語 | English |

各メニュー機能解説

ここでは、リニアングラフ3Dのメニューバーに並ぶ、各メニューの詳細機能について解説します。

※ 本文中で「 / 」区切りの項目は、前半が日本語モードでの表記、後半が英語モードでの表記です。


ファイル メニュー / File Menu

ファイルを開く / Open File

座標値ファイルを開きます。一度に複数のファイルを指定可能です。 「OPEN」ボタンを押してプロットしたい座標値ファイルを追加していき、最後に「PLOT」ボタンを押してください。

データを開く / Open Data

ファイル化されていない数列データをそのままプロットする事ができます。 「DATA:」と書かれている下の入力ウィンドウに、座標値ファイルの中身を貼り付けたり、 表計算ソフトで領域をコピーして張り付けてください。「PLOT」を押すとグラフにプロットされます。

※この操作は、グラフ画面を右クリックすると出現するメニューから、「Paste Data」を選択しても行えます。

画像の保存 / Save Image

現在のグラフ画面を画像ファイルに出力します。形式はBMP、JPEG、PNG が指定可能です。任意の名前を入力して「Save」ボタンを押してください。

画像は特に指定しない場合、開いている座標値ファイルのある場所に保存されます。任意の場所に保存したい場合は「Location」項目の「SET」ボタンを押し、保存場所を指定してください。

また、JPEG 形式画像ファイルでは、「Quality」項目で品質の指定が可能です。品質を上げるほど綺麗な画像に仕上がりますが、ファイルサイズが大きくなります。なお、BMP 及びPNG 形式では全く非劣しない完全品質で出力されます。

編集 メニュー / Edit Menu

クリア / Clear

現在のグラフ情報を全てクリアします。

範囲の設定 / Set Range

グラフにプロットする範囲を指定します。X、Y、Z それぞれに最小値と最大値を入力してください。

ラベルの設定 / Set Label

X、Y、Z 軸の名称を指定します。前後に空白を入れる事で、表示位置を左右に調整できます。

色の設定 / Set Color

グラフの色を設定します。同時に複数の座標値ファイルを読み込んだ場合、ここでの設定に基づいて色分けされます。ただし「オプション / Option」メニューで「グラデーション / Gradation」オプションを有効している場合は、ここでの設定と関係無く虹色に彩色されます。

フォントの設定 / Set Font

グラフ画像中の目盛り表示やタイトル、ラベルなどに使用するフォントを設定します。一般にフォントは著作権により保護されており、個別にライセンスが存在します。(重要)リニアングラフで作成した画像を、論文やインターネット等を通じて第三者に公開する場合は、その行為がライセンスにより許されているフォントを使用してください。

なお、ソフトウェアとの相性により使用不可能なフォントが存在するため、設定したものと別のフォントが使用される事があります。リニアングラフで初めて使用するフォントがある場合、画像を公開する前に、設定したフォントが正しく使用されているかを必ずご確認ください。

カメラの設定 / Set Camera

グラフの角度や、カメラ距離(Camera Distance)、表示倍率(Magnification)を指定します。遠近感の有無を選択する事も可能です。

遠近感

遠近感とは、「近くの箇所ほど大きく見え、遠くの箇所ほど小さく見える効果(消失効果)」の事を指します。

適度に遠近感のあるグラフは、奥行き方向の把握を直感的にサポートしてくれるため、マウスで視点変更しながらの日常の解析用途に向いています。 一方で、遠近感の無いグラフは、数学的なデータの出版用プロットなどで、一切歪みのない図を作成したい場合などに向いています。

遠近感ありに設定されている場合、その遠近感は、カメラ距離が近いほど強くなります。

▲ 左:遠近感無し、 右:遠近感あり(カメラを接近させる事で、かなり強めに調整)

目盛りの設定 / Set Scale

目盛りのデザインや書式などを指定します。まず、「フレーム / Frame」項目では、グラフの輪郭タイプを指定可能です。

フレーム項目の詳細
BOX TYPE
標準の箱型フレームです。
BACK-WALL TYPE
後ろ側の壁のみを描画し、前側の線は描画しないフレームです。
FLOOR TYPE
床のみのフレームです。
NONE
フレームを描画しません。

また、「目盛りの区間数 / Number of Sectors」項目では、目盛りの区間数を指定可能です。

さらに、「書式 / Format」項目で目盛り数字の書式を指定可能です。 書式を指定するには、「自動調整 / Auto」項目を選択解除し、「書式 / Format」の右にある入力エリアに、以下の例に基づいて入力してください。絶対値が0.1 以上10 以下の場合を独立に指定可能です。

- 入力例 -
「 1.23 」のように表示したい場合
「 0.00 」と入力してください。
「 1.23E4 」のように表示したい場合
「 0.00E0 」と入力してください。
小数を切り捨てて「 1 」のように表示したい場合
「 0 」と入力してください。

加えて、設定ウィンドウ右側に並ぶ「表示 / Visiblity」の選択項目で、目盛りの表示・非表示を場所ごとに指定可能です。 それには「自動調整 / Auto」項目を選択解除し、目盛りを表示したい部位のみを選択してください。

光の設定 / Set Light

光線の反射パラメータ設定や、光源位置の設定を行います。

反射パラメータ詳細

環境光反射率 / Ambient
全体を一様に照らす環境光反射の強度を調整します。
指向性反射強度 / Directional
光源に垂直であるほど明るく照らす指向性反射の強度を調整します。
回折性反射強度 / Diffractional
Directional では完全に陰となる部位までも多少回り込んで照らす、回折性反射の強度を調整します。
全反射強度 / Shininess、および全反射臨界角 / Shiny Angle
光沢が表れる範囲の広さを調整します。 光沢は、光源と視点との間に反射の法則が満たされる点を中心として、ここで指定した広さの範囲に表れます。

オプション メニュー / Option Menu

線プロット / With Lines

座標点を線で結ぶオプションです。

点プロット / With Points

座標点を点で描画するオプションです。

ドットプロット / With Dots

座標点を微小な点で描画するオプションです。

ボールプロット / With Balls

座標点を任意サイズの丸で描画するオプションです。

メッシュプロット / With Meshes

座標点をメッシュ(網線)で繋ぎ、面を表現するオプションです。
※ 座標値ファイルは「座標値ファイル書式」で解説しているマトリックス書式もしくは3 カラム書式で記載する必要があります。

曲面プロット / With Membranes

座標点を微小な平面で繋ぎ、曲面を表現するオプションです。光学計算により陰影や光沢が付加されます。 「Edit」メニューのSet Light 項目で光学計算の詳細な設定を行えます。 ※座標値ファイルはマトリックス書式もしくは5 章5-4 に記載の3 カラム書式で記載する必要があります。

等高線プロット / With Contour

等高線を表現するオプションです。
※ 座標値ファイルは「座標値ファイル書式」で解説しているマトリックス書式もしくは3 カラム書式で記載する必要があります。

グラデーション / Gradation

Z 値に大小によって赤?青紫までの虹色にグラデーション彩色するオプションです。

ブラックスクリーン / Black Screen

背景を黒色にするオプションです。OFF にすると白い背景になります。 黒色の背景は液晶画面での作業に適しており、白色の背景は印刷に適しています。

半透明 / See-Through

半透明化するオプションです。処理が重いので、画像を保存する直前などにご使用ください。

テッセレーション / Tessellation

各座標点の位置を保ったまま隙間を補完することで、曲面プロット時の画質を劇的に向上させるオプションです。補完モードには、各座標点の間を直線的に補完する「GRAVITIC」モードと、曲線的に補完する「PARABOLIC」モードとがあります。 これら2 つのモードを、データに応じて使い分けてください。

補完モード詳細
「GRAVITIC」モード
座標値から隣接する4 点の重心を補完し、さらにそこから隣接する4 点の重心を補完し、 この操作を永遠に繰り返した極限として得られる曲面を生成します。この補完によって得られる曲面は、 各座標点の位置を忠実にトレースし、尖り具合を元のままに保ちます。本質的に凹凸が激しいはずであるデータに向いています。
「PARABOLIC」モード
全ての座標点を中心とした大量の2次曲面(パラボラ面)を生成し、それらを特別な条件下でGRAVITIC 補完曲面と合成する事により滑らかな曲面を生成します。この補完によって得られる曲面は、 各座標点の位置を忠実にトレースしながらも、全域で微分連続なものに仕上がります。尖った箇所も丸みを帯びるので、 本来滑らかであるべきデータに向いています。
※このモードは各座標点を滑らかな曲面で繋いで補完する都合上、 元のプロット範囲から曲面の一部がはみ出る場合があります。適用後にグララの一部が欠けている場合は、 Set RangeでZ方向のプロット範囲を広げてください。

モードを選択した後は、補完密度を指定してください。 「N(X)/Cell」項目にX 方向の補完数を、また「N(Y)/Cell」項目にY 方向の補完数を指定してください。 一つの座標点がN(X)×N(Y)個の座標点に補完されます。

※補完数を上げるほど仕上がりが滑らかに仕上がりますが、処理時間を長く要します。 また、処理後のメモリー使用量や描画負荷も重くなります。 例えば5×5で補完すると、メモリー使用量や描画負荷は25倍に増大しますのでご注意ください。

軸反転 X,Y,Z / Reverse X,Y,Z

X,Y,Z 軸の方向を反転させるオプションです。なお、目盛りの表示位置を限定している場合、このオプションを使用すると目盛りの表示位置も反転します。

対数軸 X,Y,Z / Log X,Y,Z

グラフを対数軸で表示するオプションです。 このモードを使用するには、座標値データが 0 や負の数を含んでいない必要があります。

なおリニアングラフでは、対数軸の底が10 であるか自然数(ネイピア数)であるかを気にする必要はありません。というのも、底の変換公式により、両者のグラフはそもそも比例関係にあり、目盛りの数字が異なるだけです。そしてリニアングラフでは、目盛りの数字にその位置の対数値では無く、その位置の真の値を表示する仕様になっています(例えば1000 の位置には、3 ではなくそのまま1000 と表示されます)。従って、対数軸の底によらず全く同じグラフとなるため、底を気にする必要が無いのです。

対数軸表示で、目盛りの数字を綺麗に揃えるには

通常軸表示では、目盛りの数字が等差数列となるため、プロット範囲の最大値・最小値を綺麗な値に揃えていれば、 目盛りの数字も綺麗な値に揃います。しかしこれを対数軸表示で行っても、端数の多い数字になってしまします。

これを解決するには、対数軸表示における目盛りの数字が等比数列となる事を利用します。 まず、最大値・最小値を10 の何乗かに設定しておきます。 そして例えば最大値÷最小値が10 の5乗になったとすれば、目盛りの本数を5 本に設定します。 こうすると、各目盛りが公比10 の等比数列となるので、目盛り数字を綺麗に揃える事ができます。

ツール メニュー / Tool Menu

アニメーション / Animation

グラフをアニメーションとして表現するツールです。 Tool メニューからAnimation 項目をクリックすると、アニメーションを制御するためのウィンドウが出現します。 まず、アニメーションツールの下部にある「TARGET」の選択項目で、アニメーションする対象を選択してください。

TARGET項目詳細
SYSTEM-INDEX
時刻ごとに系列を切り替えてアニメーションします。
X-LINE
X 値に関してアニメーションします。
Y-LINE
Y 値に関してアニメーションします。
X-AREA
プロット範囲をX 方向へ平行移動しながらアニメーションします。
Y-AREA
プロット範囲をY 方向へ平行移動しながらアニメーションします。
LINE-TRACE
線プロットモードにおいて、最初の座標点からスタートし、最後の座標点へ向かって、徐々に線を引いていくようなアニメーションを行います。

※「X-AREA」または「Y-AREA」の場合、「Start」項目にプロット範囲始点、「End」項目に終点、「Width」項目にプロット範囲幅、「Shift」項目に時刻あたりの移動量を指定してください。

続いて、「 ON/OFF 」項目をON にするとアニメーションがスタートします。「PLAY/STOP」ボタンで一時停止や再開ができます。 一般的な動画プレイヤーのように、右側の大きなバーで任意の時刻に飛ぶ事ができます。またその下の小さなバーで再生スピードを調整できます。

数式プロット(旧バージョン) / Math (Old version)

数式から座標値データを生成し、グラフにプロットするツールです。「Z(<x>,<y>)=」と書かれた入力ウィンドウ中に数式を記述して「PLOT」ボタンを押すと、 その数式のグラフが描画されます。なお、数式中にはX 軸変数を<X>、Y 軸変数を<Y>と記述する必要があります。

※ 現在は「 プログラム / Program 」メニューから、新しい数式プロットツールが使用できます。 このツールは旧バージョンですが、こちらの操作感に慣れた方のために互換サポートしています。

プログラム メニュー / Program Menu

リニアングラフ3Dが標準サポートしているスクリプト言語である、VCSSLで記述されたプログラムを実行します。 プログラムはユーザーが作成可能で、リニアングラフ3Dを制御して、自動処理などを行わせる事ができます。 詳細は「 VCSSLによる制御・自動処理 」を参照してください。

VCSSLで記述したプログラムを「 RinearnGraph3DProgram 」フォルダ内に入れておくと、このメニューからすぐに選択して実行する事ができます。 標準では、数式プロットツールとして使えるプログラムなどが同梱されています。



スポンサーリンク


スポンサーリンク

この階層の目次
お知らせ

Vnanoのソースコードと開発リポジトリをGitHubで公開
2018年09月30日 - 現在開発中の、ソフトウェア上でのスクリプト処理用途に向けた小型・軽量スクリプトエンジン「 Vnano 」のソースコード&リポジトリを公開しました。ビルド・使用方法や、現状の段階と今後などを解説します。

リニアングラフ3D&2D Ver.5.6 リリース! Java言語のプログラムからも制御可能に
2018年08月19日 - 約5年ぶりの大きなバージョンアップを迎えた、新しいリニアングラフ Ver.5.6の特徴をご紹介します。UIがリファインされ、Java言語でグラフ描画ライブラリとして使う事も可能になりました。

ライセンスの緩和方向への改訂を実施、条件を満たす場合のソフトの再配布などが可能に
2018年07月16日 - RINEARNでは2018年7月に、ソフトウェアライセンスの緩和方向への改訂を実施しました。新ライセンスでは、いくつかの条件を満たす場合において、ソフトの再配布などが無申請で可能になりました。

コードアーカイブ新着
配列を3Dグラフにアニメーションプロットする(点/線グラフ)

座標値配列の内容を、3次元の点/線グラフに連続でプロットし、アニメーションさせるサンプルプログラムです。
2018年11月14日
配列を2Dグラフにアニメーションプロットする

座標値配列の内容を、2次元グラフに連続でプロットし、アニメーションさせるサンプルプログラムです。
2018年11月13日
配列を3Dグラフにプロットする(曲面/メッシュグラフ)

座標値配列の内容を、3次元の曲面/メッシュグラフにプロットするサンプルプログラムです。
2018年11月12日
ファイルを3Dグラフにプロットする(曲面/メッシュグラフ)

座標値ファイルの内容を、3次元の曲面/メッシュグラフにプロットするサンプルプログラムです。
2018年11月11日
連番画像をアニメーション再生する簡易ツール

フォルダ内の連番画像ファイルを、動画への変換不要で、そのままアニメーションとして再生できる簡易ツールです。
2018年09月04日
公式Twitterアカウント

スポンサーリンク